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Creating Maps in ArcMap: A Quick Guide 

Overview 
Making maps in ArcMap is very easy: Browse geospatial data in ArcMap and choose an appropriate 

presentation. This workshop will guide you through all necessary steps in the following table. 

No. Steps 
Sections 
to check 

Difficulties 

1 Load Geospatial Data into ArcMap 1.1 Data formats and folder connection 

2 
Identify the features and attributes to 
present 

1.2  
Layer order, feature selection, and 
(briefly) frequent-used projections 

3 Define how to show the data 2.2 
Transparency (raster and vector), data 
classification, and layer file 

4 Add maps components 2.3 Geospatial data references 

5 Export maps 2.4 Resolution and file formats 
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1. Browse Geospatial Data 

1.1. Load data 

To launch ArcMap, please click: Start -> All Programs -> ArcGIS -> ArcMap 10. By default, a start-up 

splash window will appear once ArcMap has loaded (Figure 1).  

Click OK to proceed. You can ignore all other options. They are redundant. 

 

Figure 1. The start-up splash window of ArcMap 

There are two ways to add data: Click the Add Data  button (Figure 2), which opens a window 

similar to Figure. 

 
Figure 2. Main Windows with Marks on Add Data and ArcCatalog 

Add Data ArcCatalog 
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Figure 3. The Pop-up Window of "Add Data" 

To browse to the file you want to play with, you can link to the folder containing all these files by clicking 

the Connect to Folder  button in Figure 3, then browse to add the folder that contains your files 

and click OK. After that, you can locate the files listed below and add them in at one time by holding the 

Ctrl or Shift button when you are clicking mouse button to make selections. Please click the Add button 

just like any other file explorer dialogs in Windows to close the dialog.  

 schools_dec06.shp: All schools in the City of Waterloo; 

 waterloo_city.shp: The administration area of the City of Waterloo;; 

 WSLSN_feb08.shp: Roads in the City of Waterloo; 

 AirPhoto.jpg: A resolution-decreased airphoto image of the City of Waterloo. 

When data is loaded, all files will be listed in the left pane (table of contents) in Figure 4. The geographic 

features (contents) are displayed in the right pane. And most controls can be found on the top pane (or 

by right-clicking on the object you are working at and checking the pop-up window). 

 

Connect to 

Folder 
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Frequently-used File Formats in ArcGIS: 
 Feature Data: Feature data are usually organized as points, lines, and polygons in vector 

format. 
o Shapefile: The most commonly used geospatial data format. Although it appears to 

be one file in ArcMap, shapefile includes multiple files with the same file name, but 
different extensions. *.shp, *,dbf, and *.shx are must-have.  

o Personal Geodatabase: These files are based on Micriosoft Access (*.mdb). From 
user perspective, all kinds of geodatabase are the same, which include multiple layers 
(different geospatial data) in one geodatabase. 

o File Geodatabase: File geodatabase is a folder that contains geospatial data, which 
is newly introduced to ArcGIS. In ArcMap, file geodatabase is shown as a file rather 
than a folder. This might be the reason why ESRI adds “connect to folder” in ArcMap 
10. Hence, when you navigate to the file you want to open but are unable to do 
so, ALWAYS check if you should go one level upper to link to the folder first. You 
can open the file in the next step. 

o Further Reading:  
 http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Types_of_g

eodatabases/003n00000007000000/ 
 http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/About_geo

graphic_data_formats/00r90000006r000000/ 
 Raster Data: Raster data uses grid to represent a region with values as a “field”. Images 

explicitly have the parameter of resolution. Typical raster data is: 
o GeoTIFF: They have the file extension of *.tif. The key difference between normal TIFF 

file and GeoTIFF is that GeoTIFF has projection information. Hence, normal TIFF files 
cannot be correctly added to the desired location. 

o GeoJPEG: Similar to GeoTIFF, but they have *.jpg extension. 
o Usage: Raster data can be air photos, satellite images, elevation data (DEM). But 

raster data tends to be huge and slow to load. 
 External Data: ESRI also supports some file formats produced by other vendors due to their 

popularity. Typical ones are: 
o AutoCAD: *.dwg files can be added, imported and converted into ArcMap. 
o Google Earth: *.kml files are supported by ArcGIS as well. However, conversion from 

KML into Shapefile is required, which can be done using ArcToolbox or some online 
services. 

o Further Reading: Wikipedia on GIS File Formats 
http://en.wikipedia.org/wiki/GIS_file_formats 

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Types_of_geodatabases/003n00000007000000/
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Types_of_geodatabases/003n00000007000000/
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/About_geographic_data_formats/00r90000006r000000/
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/About_geographic_data_formats/00r90000006r000000/
http://en.wikipedia.org/wiki/GIS_file_formats
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Figure 4. Structure of the Main Window 

 

Table of 
Contents 

Data View 
Window 

Controls and 
Menus 
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1.2. Browse Geographic Features 
In ArcMap 10, ESRI starts to put most controls to browse data into one tool bar (Figure 5). If you cannot 

find this toolbar, please go to Customize -> Toolbars and check the Tools on.   

 

Figure 5. The Toolbar with Data Browsing Controls 

Most icons are intuitive and self-explained. If you are not sure what function it has, please put your 

mouse on that icon. A pop-up text will show and further explanation. In Figure 5, an example is shown 

when the mouse is hovering over the icon . The pop-up window explains its functionality: “Select 

Features by Rectangle”, which means that you can draw a rectangle over some area, and all features 

within (or have parts within) this rectangle will be selected for further operations.  

In addition to the toolbar, some functions on attribute data are put in the pop-up window when you 

right click on one layer (a geospatial data file or a feature class) in the table of contents (Figure 6). When 

you click on “Open Attribute Table”, a table with all information on features will be shown (Figure 7). 

 

Figure 6. Pop-up Window with Options on a Layer 
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Figure 7. Attribute Data Window 

These controls can be classified and summarized into the following table: 

 Geographic Operations Attribute Operations 

Browse  
Right-click on the layer (Figure 6 and 7) 

Search/Identify 
  

Select  (Figure 7) 

 

 

Select by 
Attributes 
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2. Mapping 

2.1. Distinction between Geospatial Data and Map Components 
This section is more concept- oriented. To simplify mapping process, ArcGIS divides mapping into two 

categories: data view, which focuses on data manipulation and representation (symbology), and layout 

view, which provides functionality of adding legend, scale bar, north arrow, etc.  

 All data representations should be set in data view. Key operations include the change of layer 

order, symbology customization, layer transparency, labeling, and annotations. Most of data 

representations can be saved in a layer file (*.lyr), because they are more data associated.  

 Layout view shows the virtual map you will get. Layout view works in a What You See Is What 

You Got (WYSIWYG) fashion. The output will be the same as what you see in the layout view, 

where you can add map elements and change the paper and output settings. Map setting will be 

save in a *.mxd file. 

 

Figure 8. Switch between Data View and Layout View 

Switch Menu 

Switch Button 
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2.2. Key Options of Geospatial Data Representations 
Main options of changing geospatial data representations are layer order, layer transparency, 

symbology, label, and annotation. Apart from the first one (layer order) and last one (annotations), all 

the rest locate in the pop-up window (Figure 9) when you right-click the layer you want to modify and 

select property (Figure 10). They are under either the symbology or labels tab.  

 

Figure 9. Pop-up Window of a Layer's Property 

 

Figure 10. The Property Window 

All options will be introduced as subsections in the following. 

2.2.1. Layer Order and Transparency 

When users want to overlay airphotos (airphoto.jpg) and parcels (waterloo_city.shp) together to 

produce a map like Google Satellite View (i.e. 

http://maps.google.ca/maps?f=q&source=s_q&hl=en&geocode=&q=Waterloo,+Ontario+N2L+3G1&aq=

0&sll=49.891235,-

97.15369&sspn=41.516812,79.013672&ie=UTF8&hq=&hnear=Waterloo,+Ontario+N2L+3G1&t=h&z=15)

, the parcel layer (waterloo_city.shp) is better be made as “halo” polygons, which will be introduced 

after the concept of layer order. 

Layer Order 

Properties 

Symbology 

Labels 

http://maps.google.ca/maps?f=q&source=s_q&hl=en&geocode=&q=Waterloo,+Ontario+N2L+3G1&aq=0&sll=49.891235,-97.15369&sspn=41.516812,79.013672&ie=UTF8&hq=&hnear=Waterloo,+Ontario+N2L+3G1&t=h&z=15
http://maps.google.ca/maps?f=q&source=s_q&hl=en&geocode=&q=Waterloo,+Ontario+N2L+3G1&aq=0&sll=49.891235,-97.15369&sspn=41.516812,79.013672&ie=UTF8&hq=&hnear=Waterloo,+Ontario+N2L+3G1&t=h&z=15
http://maps.google.ca/maps?f=q&source=s_q&hl=en&geocode=&q=Waterloo,+Ontario+N2L+3G1&aq=0&sll=49.891235,-97.15369&sspn=41.516812,79.013672&ie=UTF8&hq=&hnear=Waterloo,+Ontario+N2L+3G1&t=h&z=15
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ArcMap displays geospatial data according to the order in the table of contents: the bottom layer will be 

drawn on the screen first and covered by upper layer. Hence, the layer on the top in the table of content 

will be displayed as the top layer in the map. By default, ArcMap shows points, lines, polygons, and 

raster data (images, DEMs, etc) from the top to the bottom respectively so that the visibility is 

maximized. If two layers belong to the same feature class, i.e., point features, the newly added one will 

be on top of the older one. 

When there are multiple raster files, layer visibility and order are important. You can change layer 

visibility by switching the checkboxes left to the layer name in table of contents (Figure 11). And the 

display order can be changed by simply dragging the layer toward or away from the top.   

 

Figure 11. Layer Visibility and Order Control 

Layer Visibility 

When a polygon layer, such as waterloo_city, is added over an image (airphoto), the content on image 

under the building is invisible (Figure 11). But users often like to only show the parcel’s boundary and 

remain the image displayed. In this case, layer transparency and hollow symbology can help.  

Visibility 
Checkbox 

Drag to change order 

Waterloo City as polygon 
covers the air photo 
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To do so, please right-click on the polygon layer (waterloo_city) and select Properties first (Figure 9). 

Then please switch to the tab Symbology and click on the symbol itself (Figure 12). 

 

Figure 12. Properties of Symbology 

When the pop-up window shows (Figure 13), you can change the Fill Color to No Color and increase the 

Outline Width (0.4 point is somewhat narrow).  

 

Figure 13. Make Hallow Polygons 

 

Layer Transparency: 
An alternative (actually more generic) way of preventing overlaying is right-click the layer and 
select properties (Figure 9) first, and go to the Display tab. You can freely change the 
transparency as the parameter (percentage) of “Transparent” (or “Transparency” for raster 
layers). 

Symbology Tab 

Click on the Symbol to 
Customize 

Change Fill Color to No Color 

Outline Width 
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2.2.2. Symbology and Label 

Symbology 

Symbology is critical in making maps, which are classified into four categories in ArcMap. Due to its 

complexity, these four categories and their normal usages will be briefly introduced in the note region 

with further reading. We will only focus on symbol customization and classification symbols, which are 

mostly used.  

Please right-click the schools_dec06 layer and select Properties. Then switch to the Symboloy tab and 

click on the Symbol (Figure 12). The pop-up window (Figure 14 contains three main parts. In most cases, 

you will simply choose a symbol from the symbol library (other than making hallow polygons mentioned 

in 2.2.1.). Depending on the type of the feature (point, line, or polygon), the options change accordingly. 

You can type in school and click the search icon (magnifier) to search all symbols related to school 

representations. 

  

Figure 14. Symbology Customization Window with Explanations 

There are cases when you want to differentiate features in a layer based on some attribute. For 

instance, I want to know which schools are public, separate, or for higher education in the schools layer, 

which is the top layer in Figure 11. Different types will be marked in colors. To do so, we should right-

click on the school layer, select properties, and go to the symbology tab, which is the same as shown in 

Figure 12. But, instead of by-default Features option, we should click and select the categories option 

(Figure 15). The steps to follow are also shown in Figure 15:  

1. Click on the Categories first and make sure the “Unique Value” is chosen; 

2. Draw down the dropbox of Value Field, and select TYPE as the classification attribute; 

3. Click on the Add All Values button to add all distinct values under the TYPE attribute into 

consideration; 

4.  (Optional) Click on the Color Ramp dropbox and select your favourite color schema. 

Professional 
Symbol Library 

Frequently-used Customization 
Options 

Advanced (Full) Options 

Search 
Keywords 
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Figure 15. Classifying Features using Colors 

The result is shown in Figure 16. Please note that you can still customize individual symbol for each 

category (size, shape, etc) by double clicking corresponding class on either the left pane or the line in 

symbology window (Figure 16). The pop-up window is very similar to the window in Figure 14. Please 

choose School 1  for each class. Don’t worry about the color, ArcMap can manage it. 

 

Figure 16. Classified Symbols and Further Customization 

1 
2 

3 

4 

Symbology Customization for 
an Individual Class 
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Label 

The labels are an important feature of a map. By marking some property up on the map, for stance, the 

name of the marked location, labels can make your map more useful, informative, and visually 

appealing.  

To add labels to your map, please right-click on the layer that you want to add marks on (school_dec06) 

and select Properties (Figure 12). Then follow the steps below: 

1. Select the Labels tab and check on (off by default) “Label features in this layer”.  

2. Choose the attribute you want to display (NAME) on the map in the dropbox of Label Field 

(Figure 17). 

3. Change Font (10 pt size and Bold), so that it is clearly shown on the map. 

4. You can click on the Apply button to see the effect until it is satisfactory. Then click OK to save 

your setting and exit. 

 

Figure 17. Label Setting Window 

To ensure a clear label, the option of mask can be used Symbol, which locates to the right of Font 

options as a Symbol button (Figure 17). Please click it and then click the Edit Symbol button, since label 

is a kind of symbol (text symbol) too.  Navigate to the Mask tab shown in the figure below. Change the 

option of Style to Halo (Figure 18). 

1 

2 

3 

4 
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Figure 18. Change Mask Option for Clearer Labels 

 

 

2.2.3. Annotations 

Annotations look like labels. The key difference is that annotation can be any text you want to add on 

the map, regardless to whether the information has been included in the geospatial data. 

For instance, if you want to add a point at the entrance of UW, which is not in the geospatial data, 

please follow the steps below (Please note that annotations can only be edited under the data view): 

1. Turn on the Draw toolbar. To do so, please click on the menu of Customize -> Toolbars -> Draw 

(Figure 19).  

Symbology Types and Their Normal Usage: 
 Features: Mainly used when you just want to mark geographic features on a map. 
 Categories: Suit for the case when feature classification is needed. 
 Quantities: Appropriate when numbers involve, i.e., population, income, depth, etc. 
 Charts: Employed when not only quantity but also the relative importance is important as 

well. For instance, incomes from different types of consumers. 
 Multiple Attributes: Utilized when multiple criteria are involved, which main not be 

quantitative. It can be regarded as a generalized case of Charts. 

Mask Option 
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Figure 19. The Way of Turning on the Draw Toolbar 

2. Add Marker. Click on  and select Marker. Then browse and point to the location you want 

to add the marker (South Campus Hall in this case) and click. A marker will be added to the 

location. 

 

Figure 20. The Draw Toolbar 

3. Add Text. Click   and choose Call out (or New Text). Click on the map, somewhere close to 

the marker you just made and type in accordingly (i.e. “UW Entrance”). 

Result is shown in Figure 21. 
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Figure 21. Map after Adding Labels (with Mask) and Annotations 

Some Other Types of Annotations: 
 Annotate a polygon: Sometimes you may want to annotate a polygon. The easiest way to 

do so is to choose Polygon Text. Please modify the text style (color, size, etc) and the filled 
color accordingly, which locates at the right part of the Draw Toolbar (Figure 19). 

 Annotate along the road: ArcMap also allows to you to put your annotations warp along 
the road, which looks nicer. To do so, please choose Splined Text. Then make single clicks 
along the road, which defines the display route. Type in the texts and enter. The text will 
be shown along the route you made. 
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2.3. Map Components 
When you select Layout View to start adding map components, all components are gathered in the 

menu of Insert (Figure 22). The key ones are: 

 The title of the map (Purpose/Content); 

 The scale of the map (Measurement); 

 The North Arrow (Orientation); 

 The Legend (how to interpret the map); 

 (Optional) The reference (where you obtain the data). 

 

Figure 22. All Map Components Available 

Map titles are just a specific kind of text box with some pre-defined fonts. Hence, the usage of title and 

text are identical and intuitive: type in the content and customize the text properties. 

Add scale bar or scale text is also intuitive. The only thing that should be noted as the display unit, such 

as meters, degrees, miles, etc. You can customize it by clicking the Properties button in the Scale Bar (or 

Text) Selector, which is the pop-up window when you choose Insert -> Scale Bar (or Scale Text).  In the 

Scale and Units tab, you can choose an appropriate unit in the Division Units dropbox (Figure 23). In 

addition, you can change the font style under the Format tab as well.  

In this example, please use Scale Text with meters as unites, shown like: . 

Add North Arrow is the easiest task, which is very similar to add a scale bar. Just choose a pre-defined 

north arrow from the library shown in the left pane is ok. If your North Arrow is difficult to be 

distinguished from the background, you can add some background color, which has similar effect of 

“mask” for labels. This option normally locates in the Frame tab (Figure 24). Legend, scales, and texts all 

have similar options. 

1 cm = 75 meters
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Figure 23.The  Scale Bar (or Text) Property Window 

 

Figure 24. Change Background Color in Frame Tab 

Adding Legend is somewhat complex and deserves some explanation. When Insert -> Legend is 

selected, ArcMap will use a wizard guiding you through various options of making a legend.  

At the first step, you will be asked about which layers need legend and the order of adding legend 

(Figure 25). The left pane Map Layers displays all layers (geospatial data) available for the map. The right 

pane Legend Items shows the layers that will be added to the legend in order.  

 Add/Remove Layers: You can decide the layers to be added to the legend by clicking  to add 

or  to remove. Please remove the airphoto layer, since the band information for raster 

images is not useful (Figure 24). 

Division Unit Dropbox 

Background Color Change 

Frame Tab 
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 Change the Display Orders: The legend items will be added strictly in the order shown in the 

Legend Items pane. You can change the order by clicking a layer first (displayed in the blue bar) 

and move it up  or move it down . 

 

Figure 25. The First Step of Adding Legend 

In the following three steps (four steps in total), ArcMap will ask you about some options to display the 

legend. None of them is critical and requires customization (especially for normal users). You can just 

accept all default configuration and click  next until Finish it. You will get the legend that looks like in 

Figure 26. 

 

Figure 26. An Example of Generated Legend 

It is easy to find that the name displayed in the legend is difficult to understand. For instance, users 

won’t know what “WSLSN_feb08” means. In this case, you can modify the name in the table of content 

pane (Figure 4). To do so, you can right-click on the “WSLSN_feb08” layer and select Properties (Figure 

12). At this time, please switch to the General tab. Then you can type the more meaningful name in the 

Layer Name: Roads (Figure 27). You can use the same method to change “schools_dec06” to “Schools”. 

 

Legend

schools_dec06

TYPE

3 COLLEGE

3 PUBLIC

3 SEPARATE

3 UNIVERSITY

WSLSN_feb08

waterloo_city

Obscure Name 
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Figure 27. The General Tab to Change Layer Name 

UML would like to emphasize the importance of adding references to your map. The reference clarifies 

the data source, making others easier to track, and also is good for academic integrity. Please follow 

steps below to make citation: 

1. Go to University Map Library’s main webpage at 

http://www.lib.uwaterloo.ca/locations/umd/index.html; 

2. Click on the hyperlink of “geospatial data”, which leads to 

http://www.lib.uwaterloo.ca/locations/umd/geospatial_data.html; 

3. Please read through this page, and select an appropriate link based on the location of your study 

area. In general, the closer your study area locates to Region of Waterloo, the larger geospatial data 

sets UML possesses. In our case of mapping schools in City of Waterloo, we will choose the hyperlink 

of “Region Municipality of Waterloo”, which guides us to 

http://www.lib.uwaterloo.ca/locations/umd/digital/rmow_data.html. 

4. Do not worry if your hyperlink is different from ours in this example. The citation prototype always 

locates at the bottom of corresponding page. In the example, since both vector and raster files are 

employed, two citations are needed. One is under the “City of Waterloo Municipal Data”. The other 

is under the “City of Waterloo Orthomosaic (2006)”. When either link is clicked, the citation 

prototype is at the bottom of these pages under the section “Citation”.  

5. Please copy-and-paste it as text using Insert  -> Text under the layout view and modify based on 

your citation format requirement. If the line is too long to fix the page, you can go to the property of 

the text by double-clicking on the text or right-clicking on it and choose properties. When the 

property dialog shows (Figure 28), you can split the line into two by manually enter wherever you 

want to break the line.  

Customize Layer Name 

http://www.lib.uwaterloo.ca/locations/umd/index.html
http://www.lib.uwaterloo.ca/locations/umd/geospatial_data.html
http://www.lib.uwaterloo.ca/locations/umd/digital/rmow_data.html
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Figure 28. Property Window of Text in Layout View 

Some Components that are also frequently added: 
 Author of the Map: Users may want to know who creates the map; 
 Date Saved (Created/Modified): The more frequent a region changes, the more important 

it is for users to know when the map is created; 
 Coordinate System: The globe is not flat, but a map is. Any kind of projection used to make 

the map distorts the reality in some way. Hence, it is critical for users to know how 
reliable their measurements on the map are, especially for pilots and navigators. 

Type in/Modify Text Here 
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2.4. Export Maps 
When you are satisfied with everything in the map and are ready to deliver, you can export your map by 

the menu of File  -> Export Map, which will pop-up a dialog (Figure 29).  

 

Figure 29. Export Map Dialog 

You can specify the directory and file name of the map in this dialog. But, most importantly, you need to 

choose an appropriate file format by click on the Save as type dropbox. The most frequent-used formats 

are JPEG and PDF. JPEG is a popular graphic file format, which is easy to be inserted into word as a 

graph, while PDF is best used for sharing. The printed copy of PDF will be identical regardless of your 

computer (and printer) environment.  

Please note that if the purpose of your map is to be shown on screen, 96 dpi resolution is good enough. 

It is especially true when you want to publish your map online, given that lower resolution maps are 

much smaller, and therefore, easier to transfer via Internet. If you need hard copies of your map, please 

make sure that the resolution is set to 300 dpi or 600 dpi. Otherwise the output map might be obscure. 

Other than export map to other file formats, you can directly print out hardcopies of your map by File -> 

Print. You can preview the result via File -> Print Preview to ensure satisfactory result. And, of course, 

you can customize page and printer setup via File -> Page and Print Setup, such as page orientation, 

page size, printer configuration (color or grey), and so on. All these operations are intuitive and very 

similar to other applications, such as Microsoft Word.  

Choose File Format Here 
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Created by Qian Wang 

Brief Explanation of Graphic File Formats: 
 EMF file:  Enhanced Metafile, specified for Windows, which can be regarded as an 

alternative of TIFF file. EMF is an not recommended option; 
 EPS file: Enhanced PostScript file, specified by Adobe for printer drivers. It is popular in 

open-source editors, for instance, LaTeX and TeX. But it seems to be a buggy option. Try to 
avoid it; 

 AI file: Adobe Illustrator file. A major vector graphic file format. A good choice if you work 
with Adobe products, such as Illustrator, Flash, and MacroMedia ones; 

 SVG file: Scalable Vector Graphics, an open-source vector graphic standard. It is becoming 
more and more popular and can be accepted by many vendors; 

 BMP file: BitMap file, which is a mature loss-less uncompressed raster format. The quality 
is great. But its file size tends to be huge. It can be used if you need both high-quality 
output and compatibility ; 

 PNG file: Portable Network Graphics, which is an open-source standard designed to 
replace BMP and GIF. It is a true-color loss-less raster file format. PNG file is slightly 
larger than JPEG (compressed with quality loss). And some old browsers and operating 
systems do not support PNG files; 

 TIFF file: Tagged Image File Format. A major raster graphic file format provided by 
Adobe (AI for vector). Best to be used for raster file editing on Adobe Products, such as 
Photoshop; 

 GIF file: Graphics Interchange Format. An uncompressed raster file format with 256-color 
limitation. Hence, if your map contains only a few colors (vector-based data), GIF is a 
good candidate.  


